import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".* behavior: (?<NumActive>\\d+) active, (?<NumLoading>\\d+) loading, \\d+ loaded, (?<NumFailed>\\d+) failed, \\d+ idle, (?<NumTotal>\\d+) total";
final String string = "Vyopta.vMonitor.MonitorManager: Summary: behavior: 603 active, 0 loading, 0 loaded, 180 failed, 0 idle, 783 total";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}