use strict;
my $str = 'Vyopta.vMonitor.MonitorManager: Summary: behavior: 603 active, 0 loading, 0 loaded, 180 failed, 0 idle, 783 total';
my $regex = qr/.* behavior: (?<NumActive>\d+) active, (?<NumLoading>\d+) loading, \d+ loaded, (?<NumFailed>\d+) failed, \d+ idle, (?<NumTotal>\d+) total/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}