const regex = /.* behavior: (?<NumActive>\d+) active, (?<NumLoading>\d+) loading, \d+ loaded, (?<NumFailed>\d+) failed, \d+ idle, (?<NumTotal>\d+) total/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.* behavior: (?<NumActive>\\d+) active, (?<NumLoading>\\d+) loading, \\d+ loaded, (?<NumFailed>\\d+) failed, \\d+ idle, (?<NumTotal>\\d+) total', '')
const str = `Vyopta.vMonitor.MonitorManager: Summary: behavior: 603 active, 0 loading, 0 loaded, 180 failed, 0 idle, 783 total`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}