$re = '/.* behavior: (?<NumActive>\d+) active, (?<NumLoading>\d+) loading, \d+ loaded, (?<NumFailed>\d+) failed, \d+ idle, (?<NumTotal>\d+) total/';
$str = 'Vyopta.vMonitor.MonitorManager: Summary: behavior: 603 active, 0 loading, 0 loaded, 180 failed, 0 idle, 783 total';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);