#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\w\s(а|но)[^w]"
Local $sString = "здесь но ты" & @CRLF & _
"здесь, но ты" & @CRLF & _
"" & @CRLF & _
"здесь но, как говорилось" & @CRLF & _
"здесь, но, как говорилось" & @CRLF & _
"" & @CRLF & _
"но теперь" & @CRLF & _
". но теперь" & @CRLF & _
"" & @CRLF & _
"а я" & @CRLF & _
" а я" & @CRLF & _
". а я" & @CRLF & _
"фыва а, аыв"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")