package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w\s(а|но)[^w]`)
var str = `здесь но ты
здесь, но ты
здесь но, как говорилось
здесь, но, как говорилось
но теперь
. но теперь
а я
а я
. а я
фыва а, аыв`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}