// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\w\s(а|но)[^w]").unwrap();
let string = "здесь но ты
здесь, но ты
здесь но, как говорилось
здесь, но, как говорилось
но теперь
. но теперь
а я
а я
. а я
фыва а, аыв";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}