using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w\s(а|но)[^w]";
string input = @"здесь но ты
здесь, но ты
здесь но, как говорилось
здесь, но, как говорилось
но теперь
. но теперь
а я
а я
. а я
фыва а, аыв";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}