# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z]+)\1//gi;t' <<< "Peixoto, FlorianoFloriano Peixoto\", \"de Morais, PrudentePrudente de Morais\", \"Sales, CamposCampos Sales"