$re = '/([a-z]+)\1/i';
$str = 'Peixoto, FlorianoFloriano Peixoto", "de Morais, PrudentePrudente de Morais", "Sales, CamposCampos Sales';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;