import Foundation
let pattern = #"([a-z]+)\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Peixoto, FlorianoFloriano Peixoto", "de Morais, PrudentePrudente de Morais", "Sales, CamposCampos Sales"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)