const regex = /([a-z]+)\1/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]+)\\1', 'gi')
const str = `Peixoto, FlorianoFloriano Peixoto", "de Morais, PrudentePrudente de Morais", "Sales, CamposCampos Sales`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);