using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+)\1";
string substitution = @"";
string input = @"Peixoto, FlorianoFloriano Peixoto"", ""de Morais, PrudentePrudente de Morais"", ""Sales, CamposCampos Sales";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}