re = /([a-z]+)\1/i
str = 'Peixoto, FlorianoFloriano Peixoto", "de Morais, PrudentePrudente de Morais", "Sales, CamposCampos Sales'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result