#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\bmartin_v12\b"
Local $sString = "subdomain=inzerce&page=vypis&category=autobazar&subcategory=osobni-auta¶meters=0&manufacturer=alfa-romeo_75:aston-martin_v12-vantage"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")