const regex = /\bmartin_v12\b/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bmartin_v12\\b', 'i')
const str = `subdomain=inzerce&page=vypis&category=autobazar&subcategory=osobni-auta¶meters=0&manufacturer=alfa-romeo_75:aston-martin_v12-vantage`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}