// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\bmartin_v12\b").unwrap();
let string = "subdomain=inzerce&page=vypis&category=autobazar&subcategory=osobni-auta¶meters=0&manufacturer=alfa-romeo_75:aston-martin_v12-vantage";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}