re = /\bmartin_v12\b/i
str = 'subdomain=inzerce&page=vypis&category=autobazar&subcategory=osobni-auta¶meters=0&manufacturer=alfa-romeo_75:aston-martin_v12-vantage'
# Print the match result
str.match(re) do |match|
puts match.to_s
end