import Foundation
let pattern = #"\bmartin_v12\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"subdomain=inzerce&page=vypis&category=autobazar&subcategory=osobni-auta¶meters=0&manufacturer=alfa-romeo_75:aston-martin_v12-vantage"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}