using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})(?:\+(\d{2}):?(\d{2}))?$";
string substitution = @"$1T$2Z";
string input = @"2014-10-23
2014-10-23T
2014-10-23T11:30:00
2014-10-23T11:30:00+
2014-10-23T11:30:00+0100
2014-10-23T11:30:00+01:00
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}