import Foundation
let pattern = #"^(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})(?:\+(\d{2}):?(\d{2}))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2014-10-23
2014-10-23T
2014-10-23T11:30:00
2014-10-23T11:30:00+
2014-10-23T11:30:00+0100
2014-10-23T11:30:00+01:00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1T$2Z"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)