re = /^(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})(?:\+(\d{2}):?(\d{2}))?$/m
str = '2014-10-23
2014-10-23T
2014-10-23T11:30:00
2014-10-23T11:30:00+
2014-10-23T11:30:00+0100
2014-10-23T11:30:00+01:00
'
subst = '$1T$2Z'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result