const regex = new RegExp('^(\\d{4})-(\\d{2})-(\\d{2})T(\\d{2}):(\\d{2}):(\\d{2})(?:\\+(\\d{2}):?(\\d{2}))?$', 'gm')
const str = `2014-10-23
2014-10-23T
2014-10-23T11:30:00
2014-10-23T11:30:00+
2014-10-23T11:30:00+0100
2014-10-23T11:30:00+01:00
`;
const subst = `$1T$2Z`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);