import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{4})-(\\d{2})-(\\d{2})T(\\d{2}):(\\d{2}):(\\d{2})(?:\\+(\\d{2}):?(\\d{2}))?$";
final String string = "2014-10-23\n"
+ "2014-10-23T\n"
+ "2014-10-23T11:30:00\n"
+ "2014-10-23T11:30:00+\n"
+ "2014-10-23T11:30:00+0100\n"
+ "2014-10-23T11:30:00+01:00\n";
final String subst = "$1T$2Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}