# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^A-Za-z0-9\-_\v]+)/-/gm;t' <<< "my test id
my_test_id
you're feeling replaced.
maybe? but no
what?! just a single hypen"