// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^A-Za-z0-9\-_\v]+)").unwrap();
let string = "my test id
my_test_id
you're feeling replaced.
maybe? but no
what?! just a single hypen";
let substitution = "-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}