using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^A-Za-z0-9\-_\v]+)";
string substitution = @"-";
string input = @"my test id
my_test_id
you're feeling replaced.
maybe? but no
what?! just a single hypen";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}