#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^A-Za-z0-9\-_\v]+)"
Local $sString = "my test id" & @CRLF & _
"my_test_id" & @CRLF & _
"you're feeling replaced." & @CRLF & _
"maybe? but no" & @CRLF & _
"what?! just a single hypen"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)