package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^A-Za-z0-9\-_\v]+)`)
var str = `my test id
my_test_id
you're feeling replaced.
maybe? but no
what?! just a single hypen`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}