$re = '/([^A-Za-z0-9\-_\v]+)/m';
$str = 'my test id
my_test_id
you\'re feeling replaced.
maybe? but no
what?! just a single hypen';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;