using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<b>([^<]+)<\/b>([^<]+)";
string substitution = @"";
string input = @"<table> <tbody><tr><td><b>Your boss name </b> jennefer</td></tr> <tr><td><b>your id:</b> 2241</td></tr> <tr><td><b>Email:</b> yourbossemail@gmail.com</td></tr> <tr><td><b>File Format:</b> officeial</td></tr> </tbody></table> </td>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}