$re = '/<b>([^<]+)<\/b>([^<]+)/m';
$str = '<table> <tbody><tr><td><b>Your boss name </b> jennefer</td></tr> <tr><td><b>your id:</b> 2241</td></tr> <tr><td><b>Email:</b> yourbossemail@gmail.com</td></tr> <tr><td><b>File Format:</b> officeial</td></tr> </tbody></table> </td>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;