const regex = /<b>([^<]+)<\/b>([^<]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<b>([^<]+)<\\\/b>([^<]+)', 'gm')
const str = `<table> <tbody><tr><td><b>Your boss name </b> jennefer</td></tr> <tr><td><b>your id:</b> 2241</td></tr> <tr><td><b>Email:</b> yourbossemail@gmail.com</td></tr> <tr><td><b>File Format:</b> officeial</td></tr> </tbody></table> </td>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);