const regex = /^(https?:\/\/)?(ad.doubleclick.net\/)(N2909\/)?(adj\/)([\w.]+(.dfp))(\/)?(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)?(ad.doubleclick.net\\\/)(N2909\\\/)?(adj\\\/)([\\w.]+(.dfp))(\\\/)?(.*)$', '')
const str = `<img src="http://i1.adis.ws/i/annsummers/01NWSEAS1002153_Z.jpg" height="100">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}