$re = '/^(https?:\/\/)?(ad.doubleclick.net\/)(N2909\/)?(adj\/)([\w.]+(.dfp))(\/)?(.*)$/';
$str = '<img src="http://i1.adis.ws/i/annsummers/01NWSEAS1002153_Z.jpg" height="100">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);