// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(https?:\/\/)?(ad.doubleclick.net\/)(N2909\/)?(adj\/)([\w.]+(.dfp))(\/)?(.*)$").unwrap();
let string = "<img src=\"http://i1.adis.ws/i/annsummers/01NWSEAS1002153_Z.jpg\" height=\"100\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}