re = /^(https?:\/\/)?(ad.doubleclick.net\/)(N2909\/)?(adj\/)([\w.]+(.dfp))(\/)?(.*)$/
str = '<img src="http://i1.adis.ws/i/annsummers/01NWSEAS1002153_Z.jpg" height="100">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end