import Foundation
let pattern = #"^(https?:\/\/)?(ad.doubleclick.net\/)(N2909\/)?(adj\/)([\w.]+(.dfp))(\/)?(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img src="http://i1.adis.ws/i/annsummers/01NWSEAS1002153_Z.jpg" height="100">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}