using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<street>.*) (?<number>.*)";
string input = @"Street Blah Blah 34
Überbrückerstraße 24a.
Järvägstationg. 3/B
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}