// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<street>.*) (?<number>.*)").unwrap();
let string = "Street Blah Blah 34
Überbrückerstraße 24a.
Järvägstationg. 3/B
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}