const regex = /(?<street>.*) (?<number>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<street>.*) (?<number>.*)', 'g')
const str = `Street Blah Blah 34
Überbrückerstraße 24a.
Järvägstationg. 3/B
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}