re = /(?<street>.*) (?<number>.*)/
str = 'Street Blah Blah 34
Überbrückerstraße 24a.
Järvägstationg. 3/B
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end