package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<street>.*) (?<number>.*)`)
var str = `Street Blah Blah 34
Überbrückerstraße 24a.
Järvägstationg. 3/B
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}