#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[img\]([:\/\.a-zA-Z0-9-_]+\.(jpg|gif|png|jpeg))\[\/img\]"
Local $sString = "[img]error.jpg" onerror="alert('oops')[/img]" & @CRLF & _
"[img]a-cute-bunny.jpg[/img]" & @CRLF & _
"[img]http://4.bp.blogspot.com/-JOqxgp-ZWe0/U3BtyEQlEiI/AAAAAAAAOfg/Doq6Q2MwIKA/s1600/google-logo-874x288.png[/img]"
Local $sSubst = "<img src="$1" />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)