const regex = /\[img\]([:\/\.a-zA-Z0-9-_]+\.(jpg|gif|png|jpeg))\[\/img\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[img\\]([:\\\/\\.a-zA-Z0-9-_]+\\.(jpg|gif|png|jpeg))\\[\\\/img\\]', 'gm')
const str = `[img]error.jpg" onerror="alert('oops')[/img]
[img]a-cute-bunny.jpg[/img]
[img]http://4.bp.blogspot.com/-JOqxgp-ZWe0/U3BtyEQlEiI/AAAAAAAAOfg/Doq6Q2MwIKA/s1600/google-logo-874x288.png[/img]`;
const subst = `<img src="$1" />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);