$re = '/\[img\]([:\/\.a-zA-Z0-9-_]+\.(jpg|gif|png|jpeg))\[\/img\]/m';
$str = '[img]error.jpg" onerror="alert(\'oops\')[/img]
[img]a-cute-bunny.jpg[/img]
[img]http://4.bp.blogspot.com/-JOqxgp-ZWe0/U3BtyEQlEiI/AAAAAAAAOfg/Doq6Q2MwIKA/s1600/google-logo-874x288.png[/img]';
$subst = "<img src=\"$1\" />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;