import re
regex = re.compile(r"\[img\]([:\/\.a-zA-Z0-9-_]+\.(jpg|gif|png|jpeg))\[\/img\]", flags=re.MULTILINE)
test_str = ("[img]error.jpg\" onerror=\"alert('oops')[/img]\n"
"[img]a-cute-bunny.jpg[/img]\n"
"[img]http://4.bp.blogspot.com/-JOqxgp-ZWe0/U3BtyEQlEiI/AAAAAAAAOfg/Doq6Q2MwIKA/s1600/google-logo-874x288.png[/img]")
subst = "<img src=\"$1\" />"
result = regex.sub(subst, test_str)
if result:
print(result)