using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(span).*?class=""\s*(?:.*\s)?wpcf7[^\>]*>(.*)<\/\1>";
string input = @"<span class=""wpcf7-form-control wpcf7-acceptance"">
<span class=""wpcf7-list-item"">
<input type=""checkbox"" name=""our-policy"" value=""1"" aria-invalid=""false"" class=""form-check-input"" id=""our-policy"">
</span>
</span>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}