import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(span).*?class=\"\\s*(?:.*\\s)?wpcf7[^\\>]*>(.*)<\\/\\1>";
final String string = "<span class=\"wpcf7-form-control wpcf7-acceptance\">\n"
+ " <span class=\"wpcf7-list-item\">\n"
+ " <input type=\"checkbox\" name=\"our-policy\" value=\"1\" aria-invalid=\"false\" class=\"form-check-input\" id=\"our-policy\">\n"
+ " </span>\n"
+ "</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}