const regex = /<(span).*?class="\s*(?:.*\s)?wpcf7[^\>]*>(.*)<\/\1>/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(span).*?class="\\s*(?:.*\\s)?wpcf7[^\\>]*>(.*)<\\\/\\1>', 'is')
const str = `<span class="wpcf7-form-control wpcf7-acceptance">
<span class="wpcf7-list-item">
<input type="checkbox" name="our-policy" value="1" aria-invalid="false" class="form-check-input" id="our-policy">
</span>
</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}